Exdress-Medusa Luxury Fashion Store Magento Theme

Exdress-Medusa Luxury Fashion Store Magento Theme View Demo Gallery

Exdress-Medusa Luxury Fashion Store Magento Theme


Exdress is a HQ Professional Eye-Catching Magento Theme. It is designed to delight and relax your customer’s eyes, and make him curious to continuing shopping in your Store. Go increasing your Conversion Rate with Exdress, your User Experience Magento Theme.

Main Features

Custom Megamenu – flexible menu features
  • Big Frontpage Slideshow – with various effects and caption
  • Frontpage Brands Slider – show up top brands on homepage
  • Frontpage Products Slider – flexible featured products slider
  • Frontpage Top Product – show top product on homepage
  • Frontpage Sales Product – show sales product on homepage
  • New- and Sales Products Tab – show new- and sales on category-view
  • One-Page Product Navigation – user expirience product navigation on product-view page
  • Product Image Zoom – zoomify product image feature
  • Category Filter Search – dropdown filterable category search
  • +25 Static Blocks – extensive static blocks content inclusive, all editable in admin menu
  • One-Click Installation – auto install theme, static blocks, menu and widgets

Additional Features and Information other than listed above


  • Supports Magento 1.7.0.2 /1.7.0.1 / 1.7.0.0 / 1.6.2.0 / 1.6.1.0 / 1.6.0.0 / 1.5.1.0
  • Instant quick-access shopping cart
  • Custom About-Us Page
  • JQuery tabbed additional Product Data
  • Layered PSD ’s for Customization
  • Additional Elements PSD with used Art- and Graphicswork
  • Extensive Documentation

Theme Support


First and foremost, thank you for purchasing one of my files, I truly appreciate it! Theme support will be provided by our profile’s feedback form. We will try our best, to reply to your posts/emails within 2 business days. We’re in UTC /GMT +2.
Exdress-Medusa supports Magento Community Edition 1.7.0.2 /1.7.0.1 / 1.7.0.0 / 1.6.2.0 / 1.6.1.0. / 1.6.0.0 / 1.5.1.0 – it does not support Magento Enterprise Edition and Magento GO. PHP 5 .2 or newer is also required.Don’t forget to rate my Item please.

More Items by this author

View all items